Februar 20

Linearmotor – mal in ganz klein

Servus zusammen,

jetzt habe ich mich mal wieder dem Thema Linearmotor gewidmet. Wie im Transrapid Teil 4 angesprochen, habe ich nun mit den kleinen Magneten etwas mehr experimentiert. Diesmal habe ich 13 der kleinen Magneten zu einer kleinen Kette verschalten. Diese mit ein bisschen Strom besaftet und geschaut was passiert.Anfangs ist dabei nicht viel passiert, aber erst mal genauer was ich gemacht habe:
Ganz am Anfang stand mal wieder mein CAD Programm in der Liste. Hier habe ich schnell ein paar Zeichnungen erstellt. Davor die kleinen Magnete gemessen, welche Größe die Haben: 5mm*5mm*10mm. Stimmt zwar nicht ganz, da diese kleinen Dinger an den Seiten noch „Flügel“ haben.

Magnet mit kleinen „Flügeln“ an der Seite. Hinten (dort wo die Kabel sind) ist noch der zusätzliche Permanentmagnet.

Diese kleinen „Flügel“ wurden aber für die CAD Zeichnung ignoriert, da man diese recht einfach mit einem Seitenschneider entfernen kann.
Im CAD wurden also die „Flügel“ nicht beachtet und die Zeichnung erstellt:

Gerade von 100mm Länge. Von unten (Magnete)

 

Gerade von 100mm Länge. Von oben (Fahrbahn)

14 Magnete pro 10cm. War der Plan. Das macht einen richtig schön krummen Abstand von 7,14285714286mm pro Magnet. Naja, ich muss es ja nicht messen, das Teil soll schließlich auf dem 3D Drucker gedruckt werden. In einer neueren Version ist ein Abstand von 6,25mm geplant. Damit ergeben sich 16 Magnete pro 10cm. Ein bisschen mehr, aber einfacher zu Teilen.
Das ganze ging dann wieder auf den 3D Drucker. Da der Slicer etwas Müll gemacht hat, dauerte der Druck diesmal doppelt so lang wie erwartet. Beim Infill wurde nicht optimiert sondern am Filament gespart. Keine Ahnung was er gemacht hat.
Nach 16h druck (es wurden 3 von den Teilen gedruckt) konnte es weiter gehen.

Vollen Mutes und Freude die Spulen genommen und versucht einzustecken. Ätsch. Auf der Rückseite der Magnete haben diese noch ca. 0,5mm dicke Noppen. Diese passen natürlich nicht in die vorgesehen löcher. Mir zu blöd, kurzerhand den Hammer genommen und die Magnete reingeklopft. Ging besser als gedacht.

Danach die 13 Magnete (halbe kann man leider nicht reinhämmern) miteinander verdrahtet. Jeden 4. miteinander parallel verbunden. Also drei 3er Pakete und ein 4er Paket. Die Enden der Magnete lassen sich so super löten, dass ich kurzerhand erst mal alle abgeschnitten habe, diese neu abisoliert habe und dann ging es auch mit dem Löten. Da hat wohl der Chinese zu viel Sauerstoff an die Enden gelassen, so dass alle oxidiert waren.

Danach wurde der Rest schön miteinander verdrahtet:

Gesamtübersicht über den Aufbau.links oben das Stück Straße. Oben in der Mitte mein lieblings Eingabefeld. Rechts oben der Prozessor (Arduino) mit Anschluss zum programmieren, unten in der Mitte die Treiber für die Spulen.

Die Straße einmal im Detail:

Magnet“Straße“

Und die Treiber in groß:

Treiber für die Magnete

Saft auf das System gegeben und einen kleinen Code für den Arduino geschrieben. Start gedrückt und: Wenn in dem Versuchsfahrzeug (ein KTW vom BRK) tatsächlich ein Patient gelegen wäre, dann hätte der vermutlich nochmal sein Frühstück, Mittagessen und Abendessen im KTW verteilt. Sämtliche Geräte wären aus den Schänken gefallen und die Trage hätte sich nicht entscheiden können ob sie neben den Fahrer steht oder doch lieber an der hinter Tür raus will. Selbst ein Fahranfänger fährt im ersten Gang beim Auto noch gefühlvoller als der KTW. Er ruckelte von einer Spule zur nächsten, besser gesagt er „sprang“.

Woran das Problem lag:
Ich dachte mir, dass wenn die Spulen schon Magnete integriert haben, dann kann man das doch ausnutzen und muss sie quasi nur noch mit ein Spannung diese deaktivieren und wenn man die Spannung weiter erhört wird das elektrische Feld dominant. Diese Spannung müsste sogar noch nicht mal negativ werden, da ja die Magnete vorhanden sind. Schön gedacht, aber ne, is nicht so. Also das ganze neu verdrahtet. Jetzt konnte sogar einer der Treiber entfallen, da ich die eine Hälfte der Spulen antiparall zur anderen Hälfte Schalten konnte. Neuer Test, gleiches Ergebnis. Mist. Dafür: Jetzt hat der KTW so viel „Kraft“ das der den versehentlich geparkten Schraubendreher auf der Strecke einfach zur Seite gekickt hat.

Warum geht das nicht alles nicht. Verzweiflung groß, erst mal für den ersten Teil Feierabend gemacht und mich in mein Gedankenlabor zurückgezogen.
Am nächsten Tag war dann die Idee da. Aber: Muss das echt so kompliziert sein? Die Idee: Einfach eine Phase mehr hinzufügen und statt 2 Phasen um 90° Verschoben (wie man es bei einem Schrittmotor braucht) 3 Phasen um jeweils 120° verschoben verwenden. Damit könnte es klappen. Schließlich: Jeder Drehstrommotor macht das so und jeder Brushless Motor macht das ganze so. Muss ja funktionieren. Aber: Ich muss alles neu verdrahten und brauch statt einem Treiber doch wieder zwei Treiber (um genau zu sein 1,5 Treiber). Viel zu kompliziert, das muss einfacher gehen.
Wieder Hirnschmalz durch die grauen Zellen gepresst und gegrübelt. Dann war die Idee da: Warum nicht einen 2. Magneten in das Fahrzeug integrieren und diesen im richtigen Abstand positionieren (auf die Polung auch noch achten) gesagt getan. Strom drauf. Und? Tada das Ruckeln ist nahezu weg.

Was habe ich gemacht?
Den zweiten Magnet habe ich um exakt 1,5 Spulen Abstände (exakt insofern es mir die Mittel zuließen die ich gerade zur Hand hatte: Tesafilm und Luft) versucht zu positionieren. Versucht das mal bei 7,14285714286mm Spulen Abstand :-D. Geht so lala. Den zweiten Magneten habe ich genau in anderer Polarität wie den ersten positioniert. Grob kann man sagen, mit diesem „Trick“ habe ich fast zwei weitere Phasen eingeführt, die jeweils um 90° verschoben sind. Passiert ist dann, dass nun das Fahrzeug nicht mehr „hüpft“ sondern schon fast geschmeidig gleitet. Ganz funktioniert es (noch) nicht. Ich vermute es liegt noch an den Magneten der Spule. Ein weiterer Test folgt diese Tage, bei dem ich das „Gehäuse“ von der Spule entfernen werde und das ganze nochmal aufbauen werde (Es wurden ja 3 10cm Stücke gedruckt). Mechanisch lässt es sich zumindest sehr einfach entfernen. Den Spulenkern werden ich aber beibehalten.

Hier auch das Video dazu:

Ob nun dort drauf später Autos fahren, oder der Transrapid drüber schwebt ist ja egal. Jedenfalls ein Schritt in die richtige Richtung 😀


Schlagwörter: , , , , , , , ,
Copyright 2018. All rights reserved.

Veröffentlicht20. Februar 2017 von michael in Kategorie "Basteleien am Rande", "Transrapid